[Spambayes] RE: [spambayes-bugs] SpamBayes will not stay loaded

Tony Meyer tameyer at ihug.co.nz
Fri Jul 9 05:00:58 CEST 2004


> Logfile shows these lines w/ or w/o verbose switch:
> 
> =============================  begin ============================
> Traceback (most recent call last):
>   File "pop3proxy_tray.py", line 555, in ?
>   File "pop3proxy_tray.py", line 551, in main
>   File "pop3proxy_tray.py", line 197, in __init__
>   File "pop3proxy_tray.py", line 423, in Start
>   File "pop3proxy_tray.py", line 266, in StartService 
> pywintypes.error: 
> (1058, 'StartService', 'The service cannot be started, either because 
> it is disabled or because it has no enabled devices associated with 
> it.')
[...]
> sb_tray will run if I start sb_server this way, but not 
> standalone.

So the problem is with the service specifically.  You could try uninstalling
the service ("pop3proxy_service remove") and installing it again (this is
just the service itself, so won't touch any configuration or training).

Otherwise, take a look at the service in the Windows Services control panel
(possibly under Adminisitrative Tools, depending on how your Windows is
setup).  Is it perhaps disabled there?  Or something else odd is happening
there?

=Tony Meyer

---
Please always include the list (spambayes at python.org) in your replies
(reply-all), and please don't send me personal mail about SpamBayes. This
way, you get everyone's help, and avoid a lack of replies when I'm busy.



More information about the Spambayes mailing list