[Spambayes] Check for new version shows wrong version

Tony Meyer tameyer at ihug.co.nz
Thu Jul 22 08:00:14 CEST 2004


> Earlier today, I noticed a (very) slight problem. I am running version
> 1.0rc2 of Spambayes. If I click the "Check for latest version" option
> on the system tray icon, I get a message back saying:
> 
> Current version is 0.6, latest is 0.6.

Thanks! I've checked in a fix for this.  Of course, it won't make it into a
release until 1.0.1 or 1.1a1, so it's not much good, but this is a fairly
minor thing.

> Shouldn't it say 1.0rc2? Or something similar?

This is what it will do, but the reason (in case you're curious) that it
does this is that the POP3 proxy is at version 0.6.  Originally the source &
binaries were released at different times, and it was useful to have
different version numbers for each.  These days that's rather confusing, and
people expect the version to match whatever it was that they downloaded.
This will all be cleaned up at some point, but for the moment, this is a
hangover from that.

(The Outlook plug-in was modified to print out a more understandable string
in the meantime, but I neglected to do this with the tray app until now).

=Tony Meyer

---
Please always include the list (spambayes at python.org) in your replies
(reply-all), and please don't send me personal mail about SpamBayes. This
way, you get everyone's help, and avoid a lack of replies when I'm busy.



More information about the Spambayes mailing list