[Spambayes] Unable to Access SpamBayes Browser Interface Using sb_imapfilter.py

Keith Russell usr7-28hl at xemaps.com
Sun Nov 28 02:44:13 CET 2004


Sorry for my frequent reposts on this topic in the past. I don't 
know why I'm missing messages from the list, but I just checked 
the archives and found that Tony had replied to this thread--and 
it never arrived in my inbox.

So here's my response to Tony....

Tony Meyer wrote:

>> A "telnet localhost 8880" also fails. So where do we go from here, 
>> since it seems as though I'm the only one with this bug, or 
>> whatever it may be?
> 
> What if you try another port?  (4321 or something).  (To check that it's not
> that port 8880 is unavailable, although I would expect an error in that
> case).  To do that do:
> 
>> sb_imapfilter.py -b -v -o html_ui:port:4321

Same results as before. The process starts with the expected 
output, ending in "Done." But the configuration page doesn't 
open, and http://localhost:4321 fails with "Cannot find 
server/The page cannot be displayed". Also "telnet localhost 
4321" gives an error.

> What happens if you run:
> 
>> sb_server.py -b
> 
> Can you get to the web interface then?  (If you can, then it must be an
> imapfilter problem.  If you can't, then it's either something very odd in
> the lower level web interface code, or something outside the SpamBayes
> code).

It works perfectly. The configuration page opens automatically. I 
also noticed that a message displays saying, "User interface url 
is http://localhost:8880". I don't get this with 
sb_imapfilter.py. Should I?

I should say that all these tests today were done after 
downloading and installing the new official release.

Thanks, everyone, for your help. I hate to give up on SpamBayes, 
but this problem first appeared on September 30, and I need to 
find something that works.

-- 
Keith


More information about the Spambayes mailing list