[Spambayes] flaw in 1.0

Tony Meyer tameyer at ihug.co.nz
Thu Sep 30 04:38:28 CEST 2004


> On XP you get the generic XP error message saying that the 
> exe crashed and then it asks if you want to send a report or 
> not.  If you click no, then the installer goes to the final 
> screen, which is finish.  On Win 2k, you get the generic 
> fatal application error. I clicked finish on the installer 
> and then ok on the error.  In both cases the program works 
> fine, it's just truely bizarre.  My Office Pro is fully 
> patched, SP3 and everything after it.

We've had successful reports from:

Windows       Outlook
---------------------------
98            2000 SP?
2000 SP?      2000 SP1
XP Pro SP1    2002 SP2
XP Pro SP1    2003 SP1 (x2)
XP Pro SP2    2003 SP1
2000 SP4      2002 SP3

Kenny also tested it, with (I think) XP and 2003 SP1.  Which makes it look
like it's just you, except that you're using two different machines, with
two different OS versions (although both Outlook 2000 SP3, and we haven't
tested that - and maybe 1.0rc2 was built with SP3 whereas 1.0 wasn't).

I'm quite ready to believe that the different build process is at fault
(particularly since 1.0rc2 worked for you), but I'm not sure how to track
this down - particularly since it's just the generic crash, which is no help
with figuring out the problem.

Since it is working for you, I'm inclined to leave it for the moment, and
hopefully more reports will come in and shed light.  I'll also try and get
the OL2000 machine here upgraded to SP3 and see what happens.

=Tony Meyer

---
Please always include the list (spambayes at python.org) in your replies
(reply-all), and please don't send me personal mail about SpamBayes. This
way, you get everyone's help, and avoid a lack of replies when I'm busy.



More information about the Spambayes mailing list