[Spambayes] FW: [spambayes-dev] Potential bug?

Valkyrie Publications valkyrie at valleycity.net
Thu Sep 30 08:18:14 CEST 2004


Sorry - forgot to use "reply all." Here is my email again with a few typos
fixed. As I found after I wrote it, the reason I couldn't find the zip file
on the mirror sites was that I was clicking the logo for the home page
rather than the icon for the download. Totally my own idiotic fault; too
tired at this time of night. It is impossible, as far as I could tell, to
locate the download from the home pages - at least I spent a lot of time
trying!

Thanks,

Shirley

_____________________________________
Valkyrie Publications
www.valkyriepub.com

-----Original Message-----
From: Valkyrie Publications [mailto:valkyrie at valleycity.net]
Sent: Wednesday, September 29, 2004 10:51 PM
To: Tony Meyer
Subject: RE: [spambayes-dev] Potential bug?


Sorry about that - I should have copied your post into the email; I meant
that the toolbars and folders didn't go away when it was uninstalled. In
fact, I just installed in on a second computer and trained it. Nice to have
a reason to be glad to get spam...(i.e. for training purposes)

Yes, I looked on many of the mirror aites for the .zip file and couldn't
find it. Used "search" on the University of MN site, and found articles
about it but no download - and the word "spambayes" didn't return any
results in search, nor did the name of the file. Even searched some outside
the US and couldn't find it. I used Google and found the download of the
.exe version, so I got the program.

Yes, I found the mirror sites through the sourceforge website, by clicking
the link for spambayes-1.0.zip on this page:
http://sourceforge.net/project/showfiles.php?group_id=61702. But I couldn't
find a download on any of those mirror sites that appeared on this page:
http://prdownloads.sourceforge.net/spambayes/spambayes-1.0.zip?download. I
got to those pages by clicking the logo on the left hand side; possibly the
wrong way to approach them?? It took me to the home page of each. If the
file is on them, it's not easy to find!!

Yes - outlook quit responding completely after the first time I installed
spambayes. It wouldn't send, reply, even shut down without useing ctrl alt
del; I restarted the computer several times and it still was the same. I
uninstalled spambayes, reinstalled it, and this time I restarted the
computer after installing spambayes and before opening outlook. Everything
then worked fine - so I have assumed my not restarting in between was the
problem. It is working beautifully now! This was on a Tecra 8100 with Win
98SE and Office 2000 with 3 service packs, by the way.

This didn't happen on my HP XE3 (same software), but I did restart between
installing spambayes and opening outlook.

The one with 1500 hams is eventually accumulating spams to even it up. I'd
deleted all my spam before I realized I should have equal amounts, so I
didn't train over. Used equal amounts, 50 or so, on the HP just now.

I'd be glad to let you know anything you'd like about the way this works for
me. This is a GREAT program!

Thanks!

Shirley Starke

_____________________________________
Valkyrie Publications
www.valkyriepub.com

-----Original Message-----
From: Tony Meyer [mailto:tameyer at ihug.co.nz]
Sent: Wednesday, September 29, 2004 8:24 PM
To: 'Valkyrie Publications'; spambayes at python.org
Subject: RE: [spambayes-dev] Potential bug?


> I had the same problem

This is confusing, sorry.  You refer to "the same problem" - the same as
what?  This message doesn't appear to be a reply (for example, the subject
isn't in the form "Re: another_message"), but you are obviously replying to
something.

> Found this forum because I gave
> up on the mirror sites for spambayes-1.0.zip - none of them
> had the file - so I looked for it on Google. I am now
> downloading the .exe version, which takes a while.

I'm confused here, too.  Do you mean that the various sourceforge mirrors
didn't have the spambayes-1.0.zip file?  The ones I've tested appear to, and
there have been 400-odd downloads since it was released, so it seems that
they do.  Perhaps this was a temporary problem?  In any case, the page that
you were downloading the zip from ought to have had a link to the binary as
well (note that the contents of the zip and of the exe are not the same).

I'm guessing you were not downloading from http://sf.net/projects/spambayes
or http://spambayes.org or http://spambayes.sourceforge.net, but some other
site.  Those are the official SpamBayes webpages, so it's best to use them.

Note that spambayes-dev is *not* a place to discuss SpamBayes bugs.  It's a
mailing list for people interested in the development of SpamBayes.  The
correct list is spambayes at python.org, or you can just open a report on
http://sf.net/projects/spambayes.

http://spambayes.org/contact.html has more information about the various
mailing lists.

> - the reason I was uninstalling it in
> the first place was that outlook quit working entirely after
> I installed it. Since the folders and toolbars didn't
> disappear, I thought "what the heck" and installed it again.

The toolbar not being removed after uninstall is a known bug (the FAQ refers
to it in the "how do I uninstall" question/answer).

> I learned something in the process: you MUST restart the
> computer after installing spambayes and before opening
> outlook. If you don't, outlook will not work, no matter how
> many time you restart!!!

This is not true in general (although it may have been the case for you).

> It would be good to tell people this beforehand

The chances are that something was wrong with Outlook itself, and the
restart fixed this.  Given the numbers of people that have installed the
plug-in, and that this is the first report of this problem, it seems the
most likely explanation.  If you can duplicate it (particularly on more than
one machine), then please do open a bug report.

> and also let them know beforehand that it works
> best with equal amounts of spam and ham (before they train it
> with 1500 pieces of ham and 15 spams, as I did :-p -- the
> spam is gradually catching up).

Note that training large (like 1500) numbers of messages will probably not
give you the best performance.  It's best (generally) to start with a fresh
database and just train on everything that ends up in the unsure folder (or
is misclassified).  This will be everything at first, but after about 10 ham
and 10 spam you'll get good results.

This is an area in which the documentation (etc) is a bit behind, and we are
working on fixing it - thanks for the suggestion, though.

=Tony Meyer

---
Please always include the list (	) in your replies
(reply-all), and please don't send me personal mail about SpamBayes. This
way, you get everyone's help, and avoid a lack of replies when I'm busy.




More information about the Spambayes mailing list