[Spambayes] Changing mail client to connect to "localhost"

Mark Ramras ramras at neu.edu
Mon Jan 3 03:44:01 CET 2005


I went to the SB logs in ....\Local Settings\Temp.  There were 3 text files,
SpamBayes
servers 1 - 3.

SpamBayes server 1:  "Service not available. Using thread.
Loading database... Listener on port 110 is proxying pop3.lepton.neu.edu:110
User interface url is http://localhost:8880/
Loading database... Listener on port 110 is proxying pop3.lepton.neu.edu:110
Loading database... Listener on port 110 is proxying pop3.lepton.neu.edu:110
Loading database... Listener on port 110 is proxying
pop3.lepton.neu.edu:110"

SpamBayes server 2:  "Service not available. Using thread.
Loading database... Listener on port 110 is proxying pop3.lepton.neu.edu:110
User interface url is http://localhost:8880/
Traceback (most recent call last):
  File "pop3proxy_tray.py", line 524, in CheckVersion
  File "spambayes\Version.pyc", line 151, in fetch_latest_dict
  File "urllib2.pyc", line 129, in urlopen
  File "urllib2.pyc", line 326, in open
  File "urllib2.pyc", line 306, in _call_chain
  File "urllib2.pyc", line 901, in http_open
  File "urllib2.pyc", line 886, in do_open
URLError: <urlopen error (7, 'getaddrinfo failed')>"

SpamBayes server 3:  "Service not available. Using thread.
Loading database... Listener on port 110 is proxying pop3.lepton.neu.edu:110
User interface url is http://localhost:8880/"

       I also tried "telnet localhost 110".  Error message is shown below.
I'm confused about localhost 110 vs localhost 8880.
Mark

----- Original Message ----- 
From: "Tony Meyer" <tameyer at ihug.co.nz>
To: "'Mark Ramras'" <ramras at neu.edu>; <spambayes at python.org>
Sent: Sunday, January 02, 2005 8:05 PM
Subject: RE: [Spambayes] Changing mail client to connect to "localhost"


> > Still in trouble!  Here's what I've done.
> >     1)  Right clicked on SB Icon Tray and chose "Configure".
> >     2)  In POP3 Proxy Options:
> >             Remote Servers:  filled in "pop3.lepton.neu.edu"
> >             SpamBayes Ports:  110
> >             SMTP Proxy Options:  left blank
> >     3)  In Outlook Express, for the incoming POP3 mail
> > server, replaced "pop3.lepton.neu.edu" with "localhost".
>
> That all sounds correct.
>
> > When I then ask Outlook Express to "receive all", I
> > get an error message:
> > "The connection to the server has failed.  Account:  lepton.neu.edu.
> > Server: 'localhost' ."
>
> SpamBayes is running at this time, right?  (i.e. the tray icon is there
and
> not disabled).  Are there any error messages in the SpamBayes logs?  (The
> troubleshooting guide explains where they are).
>
> Try connecting to the proxy manually:
>
>  1. Open a command prompt (e.g. Start->Run->cmd.exe)
>  2. Type "telnet localhost 110"

I tried this, and got the error message:
            Can't connect to pop3.lepton.neu.edu:110:  <7, 'get addrinfo
failed'>

>
> That should open up a connection and you should see some sort of welcome
> message from the lepton.neu.edu POP server.  If it does, then just type
> "QUIT" and return to disconnect.
>
> If that does connect, then SpamBayes is working fine, and something is odd
> with Outlook Express.  (Are you connecting via SSL?)
>
> If that doesn't connect, then something isn't working with SpamBayes - the
> log should have more clues.
>
> =Tony.Meyer
>
> -- 
> Please always include the list (spambayes at python.org) in your replies
> (reply-all), and please don't send me personal mail about SpamBayes.
> http://www.massey.ac.nz/~tameyer/writing/reply_all.html explains this.
>




-- 
No virus found in this outgoing message.
Checked by AVG Anti-Virus.
Version: 7.0.298 / Virus Database: 265.6.7 - Release Date: 12/30/2004



More information about the Spambayes mailing list