[Spambayes] SpamBayes 1.0.4

Tony Meyer tameyer at ihug.co.nz
Wed Mar 30 01:59:08 CEST 2005


> I have just this morning downloaded v1.0.4 of SpamBayes Outlook
> plugin binary.  Unfortunately, when I (re)start Outlook I get the
> "SpamBayes could not be initialised" message.  The log file is
> attached - something to do with python?  The plug-in is enabled
> in the Outlook COM plugs-in options page.  I have restarted, but
> to no avail.
>
> A couple of weeks ago, I tried with v1.0.3, but I couldn't even
> get the plug-in to enable in Outlook (although it was listed).
>
> For your information, I am running Outlook 2000 SR-1 (9.0.0.4527)
> under NT 4.00.1381 (SP 6)

Unfortunately, it appears that 1.0.3/1.0.4 do not work with NT 4:

[ 1115105 ] Binary will not work with NT
<http://sf.net/tracker/index.php?func=detail&aid=1115105&group_id=61702&atid
=498103>

I believe that the problem is a bug with the pywin32 package, which
SpamBayes uses.  Although this bug has been fixed in pywin32, there hasn't
been a new release of that package for a while, which means that 1.0.3 uses
the same version as 1.0.4.  When there is a new release available, then
SpamBayes will definitely use that.  I might look at manually patching the
version we use for 1.1a1 so we can at least verify that this is indeed the
problem.

As far as I know, 1.0.1 will work with NT, however, so for the moment I
recommend using that, if possible.

(You can monitor the tracker above, or just look for the bug id# in the
release notes, to see when we believe it is fixed).

=Tony.Meyer

-- 
Please always include the list (spambayes at python.org) in your replies
(reply-all), and please don't send me personal mail about SpamBayes.
http://www.massey.ac.nz/~tameyer/writing/reply_all.html explains this.



More information about the Spambayes mailing list