[Spambayes] mac os x install error

Tony Meyer tameyer at ihug.co.nz
Mon May 2 02:23:03 CEST 2005

> but, onto the next problem, now when i try to run the
> sb_server.py program (from terminal), i get 
> Traceback (most recent call last): 
> AttributeError: State instance has no attribute 'lang_manager'
> I'm using the 1.0.4 on python 2.3. anyone seen this?

When you were trying to get things to work earlier, did you perhaps download
1.1a1 and try to install that?  It looks like what has happened is that you
have installed the 1.1a1 spambayes package, but are using the 1.0.4 scripts.

Try doing the "setup.py install" again, but adding "--force" (which will
force overwriting of any existing SpamBayes install), ensuring that you are
installing 1.0.4 and not 1.1a1.


Please always include the list (spambayes at python.org) in your replies
(reply-all), and please don't send me personal mail about SpamBayes.
http://www.massey.ac.nz/~tameyer/writing/reply_all.html explains this. 

More information about the Spambayes mailing list