[Spambayes] install error -- python or spambayes?

Tony Meyer tameyer at ihug.co.nz
Mon May 16 02:17:32 CEST 2005


> I'm trying to install spambayes 1.0.4 in a *nix account, and there
> seems to be a reasonable installation of python 2.3 on the machine. 
> Nonetheless, after unzipping and de-tarring the source code, I get the
> following error:
> 
>     % python setup.py install
>     running install
>     error: invalid Python installation: unable to open
> /usr/lib/python2.3/config/Makefile (No such file or directory)

I believe (Googling seems to back this up) that this means that you need to
install the python-devel (or however your system spells it) package to use
distutils.

(You can use SpamBayes without running setup.py, of course - just manually
put the spambayes package directory on the PYTHONPATH, and run the scripts
from wherever you like).

=Tony.Meyer

-- 
Please always include the list (spambayes at python.org) in your replies
(reply-all), and please don't send me personal mail about SpamBayes.
http://www.massey.ac.nz/~tameyer/writing/reply_all.html explains this. 



More information about the Spambayes mailing list