[Spambayes] scan two outlook imap folders ?

Keith Weng keith at keithweng.com
Tue Sep 27 19:24:06 CEST 2005

Summary: with two folders selected for the outlook spambayes plugin v1.0 to
scan when messages arrive, there seems to be a very long delay (minutes)
before it does anything after messages arrive, and even then doesn't seem to
run fully everywhere.


Spambayes was working well with no obvious delays on my outlook->IMAP inbox
when there was only one folder selected for scanning.

Then I added an outlook rule to move some incoming mail (arriving from one
particular account) from the inbox into a different folder on the IMAP
server as it arrives, and added that folder to the spambayes configuration
for "filter the following folders as messages arrive"  (ie both it and the
primary inbox are checked in the dialog that shows the folder tree with a
checkbox beside each folder.)

I have the initial delay set at 2 secs, and the interval between messages at
1 sec.

The 2ndary folder is my list of IMAP "subscribed" folders.  The INBOX is as
well obviously, no choice there.

If I click on the 2ndary folder, and after a moment I see all the headers
for all the new messages update, outlook then just sits there for several
minutes before spambayes starts doing anything.   It eventually seems to run

Meanwhile, in the primary INBOX, sometimes it doesn't ever seem to run at
all, or perhaps it tags one in ten obvious spam as such, when before it
would have gotten them all.

Any ideas what's going on ?



More information about the SpamBayes mailing list