[Spambayes] updating from 1.0.4 to 1.1a3

Claude Jones claudejones at tehogeeservices.com
Fri Oct 27 07:22:43 CEST 2006


On Thu October 26 2006 10:21 am, Claude Jones wrote:
> I'm currently running 1.0.4 on a Fedora Core 5 box using the
> proxy server. I'm happy with the results, but getting deluged
> with the new graphics based spam, and would like to try 1.1a3
> Is it possible to just unpack the tarball and run it? Will it
> just replace my current installation? I'm asking because I've
> had problems previously uninstalling and reinstalling
> Spambayes, and I'm hoping I don't have to bother with an
> uninstall, unless I need to revert back to 1.0.4 later.

A couple of folks responded to this, but they only came to me 
privately. I'm posting those responses in case they may be of 
assistance to others. 

I run SpamBayes from the CVS repository and never uninstall, so I 
suspect you'll be okay just installing 1.1a3 over 1.0.4.  You 
will also need to install PIL 
(http://www.pythonware.com/products/pil/) and ocrad
(http://www.gnu.org/software/ocrad/ocrad.html) to take advantage 
of the OCR capabilities.  You should probably also install PyDNS
(http://pydns.sourceforge.net/) to get the 
domain-name-to-ip-address
mapping.  It's unfortunate that there are external dependencies, 
but we don't have the resources to reinvent a bunch of different 
wheels. Sourceforge doesn't emphasize the release notes, but they 
are there:

    
http://sourceforge.net/project/shownotes.php?release_id=442102&group_id=61702

and should be at least glanced at.

Skip

Thanks, Skip - Looks like I need to do some reading to understand 
how to implement these new features. I'll be unable to devote any 
time to this till next week because of some major work 
obligations over the next few days, but I look forward to doing 
so. For the record, I now run Spambayes and Spam Assassin using 
KMail as my client. I let Spam Assassin have first crack and 
Spambayes gets the rest. I'm currently catching around 98% or so 
of my spam - over 300 messages a day, so, I'm not complaining. 
But, the spammers keep coming at us with their evolving tricks, 
so...

And there was also this response:

I upgraded 1.0.4 to 1.1a3 using the Outlook addin, which runs a 
utility to convert the database format from 1.0 to 1.1 upon 
installation.

The 1.1a3 has not been catching the graphics spam either, 
definitely the key will be integrating the OCR stuff.

thanks, Roland;

I run Spambayes on a number of Windows machines, but, that's not 
something I'll be updating soon. For my own Windows machine, I 
only use Outlook as an archive for my mail. I do all my reading 
on my Linux boxes, because I hate Outlook - the silly excuse  
they have for threaded mail reading called 'conversations' is 
pathetic and makes it painful to really follow threads. But, 
thanks for your comments - others may find them of interest. 

-- 
Claude Jones
Brunswick, MD, USA


More information about the SpamBayes mailing list