[Spambayes] SpamBayes 1.1a4 crashes when first starting up after reinstalling...

Taed Wynnell TWynnell at vertical.com
Fri Jan 29 17:52:02 CET 2010

After 6 months, this was resolved by disabling DEP for Outlook.  (This
is sent to the list so that others searching might find my answer.)
In expectation of this day, I still have all my saved Spam for the last
10 years (49,313 items), so retraining and getting back to where I used
to be was no problem.
And, of course, the solution is sitting right in the FAQ:

5.8   After installing SpamBayes, Outlook crashes and then asks for the
plug-in to be disabled. <http://spambayes.sourceforge.net/faq.html#id68>

Are you using an Athlon 64 or Core 2 Duo with DEP? There are issues with
DEP and Outlook with a SpamBayes-based plug-in. Listing Outlook as a
safe application on these processors should "solve" the problem.


From: Taed Wynnell 
Sent: Wednesday, June 17, 2009 3:59 PM
To: 'spambayes at python.org'
Subject: RE: SpamBayes 1.1a4 crashes when first starting up after

I still haven't been able to get any farther on this, despite a few more
attempts.  Is there some way to at least get a dump file so that I would
look at the crash in WinDbg and hopefully find an obvious problem?


From: Taed Wynnell 
Sent: Monday, June 15, 2009 10:44 AM
To: 'spambayes at python.org'
Subject: SpamBayes 1.1a4 crashes when first starting up after

I just got a new machine running Windows XP SP 3 and Outlook 2003.  Both
are completely updated.
I first installed SpamBayes 1.0.4, and that went fine, but I ran into an
old bug, so I decided to install 1.1a4 (which I should have just done
from the start).
When Outlook restarts, the SpamBayes Outlook COM object is disabled, and
just re-enabling it does not work.  So, I have to Add it back in.  Once
I do that, it then crashes Outlook with the following.  I can't get any
more crash information since the "more information" can't be
cut-and-pasted and I can't find any info stored in a file.
AppName: outlook.exe      AppVer: 11.0.8217.0     AppStamp:480f95d9
ModName: unknown      ModVer:      ModStamp:00000000
fDebug: 0       Offset: 119cf550

The SPAMBAYES1.LOG contains only:
Registered: SpamBayes.OutlookAddin
Registration complete.

I have tried a number of times to uninstall it (and even hunted down and
deleted all references to "SpamBayes" in filenames and the Registry),
but I still get the same crash.
I feel that I'm not completely cleaning up since the SpamBayes Outlook
COM object is always disabled after I uninstall and then reinstall it.
Does anyone have any assistance to offer?  I've tried everything that I
can think of.
(By the way, I have been using SpamBayes for about 5 years on my old
machine and I love it.  I had even saved my 50,000 or so spam messages
for the inevitable retraining.)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/spambayes/attachments/20100129/799b0755/attachment.htm>

More information about the SpamBayes mailing list