[Tkinter-discuss] Trouble installing PyBWidgets

Michael Lange klappnase at web.de
Mon Sep 12 21:04:12 CEST 2005

On Mon, 12 Sep 2005 13:42:33 -0400
"gilcneth at earthlink.net" <gilcneth at earthlink.net> wrote:

> Hello All:
> I am having trouble getting the PyBWidgets plugged in correctly in a Windows XP environment.  It appears to be path-related, since the BWidget package can't be found.  The installation 'Read Me' indicates that I should 'package require'--what does this mean and how would I do this?
Hi Chris,

"package require .." is something like the tcl equivalent to python's "import ...".
However, you shouldn't have to bother with this, it's something the python module should do for you.
Did you run the setup.py, and if yes, where did it install the BWidgets ?
On my linux box they're in /usr/share/pybwidget , I'm not sure about windows, but I think somewhere in
your Tcl folder should work.



More information about the Tkinter-discuss mailing list