[Tkinter-discuss] Rebuilding tkinter using VC8

Henry S. Thompson ht at inf.ed.ac.uk
Mon Jan 15 15:43:35 CET 2007

Hash: SHA1

Howard Lightstone writes:

> I am having some difficulties rebuilding tkinter using VC++ 
> 2005 (the only M$soft compiler you can buy now).
> I was able to get Python 2.5 to rebuild.  I had to get tcl/tk 
> 8.4.14 to be able to compile with VC8 (using the kind of 
> process specified in the python build documentation). 
> Tix, however, will not build using either 8.4.0 or 8.4.2.  It looks 
> like the VC8 makefile changes have never made it there.

Are you _sure_ that using gcc won't work for you?  After a lengthy,
complex and not completely successful attempt to use the (free)
Microsoft Visual C++ Toolkit Compiler per the Python 2.4 Extensions w/
the MS Toolkit Compiler instructions [1], I switched to using the
Mingw/MSYS approach [2].  Works well for 2.4, should work for 2.5 as
far as I can see.


[1] http://www.vrplumber.com/programming/mstoolkit/
[2] http://www.mingw.org/MinGWiki/index.php/Python%20extensions
- -- 
 Henry S. Thompson, HCRC Language Technology Group, University of Edinburgh
                     Half-time member of W3C Team
    2 Buccleuch Place, Edinburgh EH8 9LW, SCOTLAND -- (44) 131 650-4440
            Fax: (44) 131 650-4587, e-mail: ht at inf.ed.ac.uk
                   URL: http://www.ltg.ed.ac.uk/~ht/
[mail really from me _always_ has this .sig -- mail without it is forged spam]
Version: GnuPG v1.2.6 (GNU/Linux)


More information about the Tkinter-discuss mailing list