[Tkinter-discuss] Python2.5.1+Tkinter+Tile0.8.2

Russell E. Owen rowen at u.washington.edu
Mon Jan 12 21:17:43 CET 2009


In article <20090112154035.GA11443 at lairds.us>,
 Cameron Laird <Cameron at phaseit.net> wrote:

> On Fri, Jan 02, 2009 at 04:17:29PM +0000, Nawal <Galileon> Husnoo wrote:
> 			.
> 			.
> 			.
> > I'm just starting out in Python Tkinter programming, and I tried to use the
> > Tile module to improve the looks of the Tk program I am writing.
> > 
> > When I run the script written in <code></code> below, it works fine, using
> > the Tile module to make the Tk look ok. However, when I try to use
> > tkMessageBox.showwarning() as in the script, it fails with the error below.
> > I've tried to cat | grep for "background" in the files mentionned in the
> > error, but nothing turns up. I can't find where the "-background" switch is
> > getting stuck in. I know the "background" switch doesn't work with Tile, but
> > I can't find it to remove it. Any ideas please?
> 
> Can you upgrade to 8.5 of Tk?  <URL:
> http://tkinter.unpythonic.net/wiki/tk85_and_python >
> might help you.

Is that safe? I thought Python 2.5 was not fully compatible with Tcl/Tk 
8.5.

-- Russell



More information about the Tkinter-discuss mailing list