[Tkinter-discuss] python 3.1 - tkinter 8.4 - no tile?

David Cortesi davecortesi at gmail.com
Wed Aug 4 07:26:22 CEST 2010

Hello. I'm beginning to explore Python 3 and tkinter (using Mac OSX 10.6).
Following the directions in (http://wiki.python.org/moin/TkInter) I verified
>>> import tkinter
>>> tkinter._test()
does indeed open a little window as expected. So there is SOME fashion of
tkinter and TCL/TK installed on this machine.

Next I attempt to run the "First (Real) Example" in (
http://www.tkdocs.com/tutorial/firstexample.html), but get the error,

line 47, in _load_tile  master.tk.eval('package require tile')

Looking at the ttk.py file I find it checks tkinter.TkVersion < 8.5, and in
fact tkinter.TkVersion yields 8.4.

Performing the following google search,

     site:mail.python.org 'package require tile'

I observe that this same error has been mentioned 66 times over the last few
years and with several versions of Python and different platforms. (It seems
odd, when this problem has been arising since 2004, the latest version 3.1.2
of Python is still distributed with tkinter 8.4 and yet no tile package. But
I digress.)

The usual advice is to install the tile package from sourceforge. So I tried
to do this but encountered several problems, beginning with, where, ie what
folder? Doesn't really matter, as I find that its ./configure script looks
for a C compiler -- and the Apple Developer package is not installed on this
system. I looked around in /bin and /usr but there doesn't seem to even be a
lowly cc anywhere.

I'd appreciate any suggestions to get past this stone wall.


Dave Cortesi
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/tkinter-discuss/attachments/20100803/b55976fe/attachment.html>

More information about the Tkinter-discuss mailing list