[Tkinter-discuss] tkinter X11 vs Aqua on a Mac

Ned Deily nad at acm.org
Fri Oct 15 07:44:25 CEST 2010

In article <29919353.post at talk.nabble.com>,
 embirath <embirath at gmail.com> wrote:

> Thanks Kevin. Of course, when I try to install python through Fink I run into
> some errors: "could not  determine XFree86 version number". I'll have to
> work more on this next week, but if you have any advice let me know. 

Use MacPorts.  On  both10.5 and 10.6, I've installed the current 
MacPorts python2.6 and python3.2 which links with the MacPorts Tk 8.5.  
That pulls in the MacPorts X11 client libraries but it works just fine 
with the Apple-supplied X11.app, i.e. no need to build an Xserver.

 Ned Deily,
 nad at acm.org

More information about the Tkinter-discuss mailing list