[Tkinter-discuss] python 3.1 - tkinter 8.4 - no tile?

Kevin Walzer kw at codebykevin.com
Thu Sep 2 15:41:36 CEST 2010


> The Python distributed with OSX is 2.x. If you want to use Python 3.x and
> install it from the python.org <http://python.org> dmg, the same problem
> arises (the issue that began
> this thread). Apparently, all versions for OSX must be installed by
> compiling
> from source if Tk is to be used.

Also true.

Apple ships Tk 8.4 mainly for backwards compatibility, and the MacPython 
maintainers target this version for Tkinter to link to, also for 
backwards compatibility.

I believe ActiveState's Python distribution supports 8.5 on the Mac, by 
the way.

--Kevin

-- 
Kevin Walzer
Code by Kevin
http://www.codebykevin.com


More information about the Tkinter-discuss mailing list