[Tkinter-discuss] Python3.1 mac os

Ned Deily nad at acm.org
Sat Jul 16 00:01:03 CEST 2011


In article 
<CACedRDyWE0KYPMfsnc47xH-HMpobOg0sxJwtSs1-Uz=+HkoNtA at mail.gmail.com>,
 Georges Arsouze <georges.arsouze at gmail.com> wrote:

> Hi
> sorry for my poor english
> 1) I'm working on mac os  snow leopard 10.6 and python 3.1
> I want to use the ttk and tix widgets
> 
>  I have an error message : require tile

Apparently Tix is not shipped by default with ActiveState Tcl because 
Tix is considered out-of-date.  However, it appears you can install a 
version (for Tk 8.4 at least, which the python.org binary installers for 
Python 3.1 uses) via the ActiveState teacup package manager:

sudo /usr/local/bin/teacup install Tix

Keep in mind that Python 3.1 has been superseded by Python 3.2 (3.2.1 is 
current).  I f you are just starting with Python, you should consider 
using it:

http://www.python.org/download/

http://www.python.org/download/mac/tcltk/

http://groups.google.com/group/comp.lang.python/browse_thread/thread/878b
8a1d9e6d92ce/6f257a1c60ab50f2

-- 
 Ned Deily,
 nad at acm.org



More information about the Tkinter-discuss mailing list