[TriZPUG] managing python versions as well as package versions, or "up-to-speed for the ecosystem"

Josh Johnson josh_johnson at unc.edu
Wed Aug 3 22:01:02 CEST 2011

1. I haven't had trouble getting multiple pythons to install in Ubuntu. 
They play pretty well together. The hard part was finding the right apt 
repository with the right versions in it.

2. Maybe install a specific version of yatiblog (no experience with that 
package myself), that doesn't have a requirement on whatever is causing 
the version conflict?

3. Typically, that would entail just a link to 
http://www.python.org/download/ and a note saying "or, use your system 
package manager to install".

I'd suggest virtualenv in general, but like you mentioned it may not fix 
your problem. You can try compiling python from source (installing the 
build-dep for whatever version(s) of python are available for your 
distro might help smooth out the process)

I can say I've never, ever had a version conflict when installing a 
package :). It might be silly, but maybe try easy_install instead of pip?


On 8/3/2011 3:52 PM, Tom Roche wrote:
> summary: I'm having a particular problem involving docutils, python,
> ubuntu, and sloth; I'd most appreciate help with that problem. However
> my inability to solve my problem seems due to ignorance as well as
> sloth, so I'd appreciate pointers to doc regarding python package/
> project/version management best practices more generally, and preferably
> targeting folks who've coded a lot outside python and its ecosystem but
> not so much inside/with.
> details:
> I'm currently running
> $ lsb_release -ds
>> Ubuntu 10.04.3 LTS
> way downlevel I know, and I should be upgrading Sometime Next Week
> (famous last words :-) but at least it's up-to-date
> $ uname -rv
>> 2.6.32-33-generic #71-Ubuntu SMP Wed Jul 20 17:27:30 UTC 2011
> except that
> $ python --version
>> Python 2.6.5
> I'm trying to fix a doc problem on a site that uses yatiblog, but
> $ pip install yatiblog
> ...
>> VersionConflict: (docutils 0.6 (/usr/lib/pymodules/python2.6), Requirement.parse('docutils>=0.7'))
> which I take to mean that "yatiblog requires docutils>=0.7, and
> docutils>=0.7 requires python>2.6" (esp since I get the same dopeslap
> from
> $ pip install 'docutils>=0.7'
> ...
>> VersionConflict: (docutils 0.6 (/usr/lib/pymodules/python2.6), Requirement.parse('docutils>=0.7'))
> ). Is that correct? If so, then (transitively), to get yatiblog I need
> to get python>=2.7. So I'm wondering
> 1 What's the easiest or best way to globally install a more-uplevel
>    python on a given release of ubuntu, without hosing the global/
>    official/default/downlevel python, much less my debian/ubuntu/aptitude
>    packages and their managers?
> 2 Instead of doing global installs, I'd like to do (though I haven't
>    needed to, yet) isolated installs. But my impression is that (e.g.)
>    visualenv won't help with python-version problems, only
>    python-package-version problems. Am I missing something? If not,
>    should I use pythonbrew? or similar?
> 3 Periodically trizpug has threads on "getting started with python," but
>    they tend to be like "learning programming with python." I'd
>    appreciate pointers to doc more about the "python ecosystem"
>    (particularly, ... wait for it ... python-version and
>    python-package-version management :-) targeting folks who've grown up
>    programming elsewhere. FWIW I've scanned through
> http://trizpug.org/up-to-speed/
>    and am not seeing anything like that, but ...
> I Could Be Missing Something, Tom Roche<Tom_Roche at pobox.com>
> _______________________________________________
> TriZPUG mailing list
> TriZPUG at python.org
> http://mail.python.org/mailman/listinfo/trizpug
> http://trizpug.org is the Triangle Zope and Python Users Group

Josh Johnson
Applications Analyst
Translational Pathology Laboratory
Lineberger Comprehensive Cancer Center
University of North Carolina at Chapel Hill

More information about the TriZPUG mailing list