[Tutor] Does expy-4.0a works on NT 4.0 platform ?

Ke-Hsiang Shao KShao@AstralPoint.com
Wed, 4 Aug 1999 19:34:58 -0400


Hi there,

I found the expect 5.21 on http://expect.nist.gov/ works with TCL 8.0. The
expy-0.4a.tar.gz I got from string-SIG coordinator has been tested with
Python 1.2, Tcl 7.3 and Expect 5.13.0.

My questions are

1) Is this version expy-0.4a works on NT 4.0 ?
   (I found the installation instruction ask me to recompile the Pathon. But
I failed to run it on NT 4.0. All the instructions looks like UNIX/Linux
platform to me.)

   If the answer is no, is that means so far there is no way to run EXPECT
on Python under NT 4.0 platform ?

2) If this version works on NT 4.0, do I have to run this with "Python 1.2,
Tcl 7.3 and Expect 5.13.0" ?

---------------------

I also found expectpy 1.8.2 has been ported to Linux (please see
http://x23.deja.com/[ST_rn=ps]/getdoc.xp?AN=497964257&CONTEXT=933804116.1882
915025&hitnum=9). Does anyone know is any expect running on Python NT
platform ?

---------------------

Another place
(http://x23.deja.com/[ST_rn=ps]/getdoc.xp?AN=498341988.11&CONTEXT=933804116.
1882915025&hitnum=43) mentioned a pre-release Python PIPE can play the
expect-like function. Is this work on NT platform ?

Thanks in advance

Cary Kehsiang   email:  Shao cary_shao@yahoo.com
Astral Point Communications, Inc.   kshao@astralpoint.com
27 Industrial Ave., Chelmsford, MA 01824
Phone: (978) 256-9984         Fax:     (978) 256-6128