[Tutor] IDLE in linux

Michael P. Reilly arcege@speakeasy.net
Wed, 19 Dec 2001 18:43:16 -0500

On Mon, Dec 17, 2001 at 09:07:51PM -0500, Jeff Jones wrote:
> Well, thanks to the help of many fine python tutor mail list subscribers,
> especially Rob for his help off list, I was finally able to properly install
> and configure Slackware, X, and Gnome. I thought it fitting that Python be
> the first program I compile with my new Linux wings, and everything went
> great except I cannot use IDLE. I went into
> /usr/local/Python2.2c1/Tools/idle and the idle command is there, but when I
> try to run it from bash I get "command not found". I tried to run it in X
> and out. I also tried at python command line without success. Thanks in
> advance for any assistance. I hope this is within the scope of the e-mail
> list...

You might want to check the "shebang" line (first line in the file)
to make sure the pathname of the interpreter in

is correct (sometimes it is /usr/local/bin/python when it is really
in /usr/bin/python or /usr/local/bin/python2).