[Tutor] upgrading idle

Brad Chandler mbc2@netdoor.com
Fri, 12 Jan 2001 10:28:22 -0600

----- Original Message -----
From: "Tom Connor" <"duckpond(no spam)"@early.com>
To: <tutor@python.org>
Sent: Friday, January 12, 2001 10:04 AM
Subject: [Tutor] upgrading idle

> I have python 1.5.2 installed on RH Linux 6.2 in /usr/bin/.  I tried
> updating idle from 0.4 to 0.5 but could not get it operating as the
> default.  So I upgraded to Python 2.0 and it is located in
> /usr/local/bin.  Python 1.5.2 is also there and I am having the same
> idle problem, I get the old idle.  Will uninstalling Python 1.5.2 solve
> this problem?

I had this same problem when I upgraded to python 2.0. I had both the old
and new binaries on my system and everytime I started python, it used the
old binary instead of the new one. I think it was because I had a symbolic
link from python1.5.2 to python. I deleted the old binaries from my system,
deleted the old symbolic link, and then created a new link from
/usr/local/python2.0 to /usr/local/python. Its worked fine since then. Make
sure you check in both usr/bin and usr/local/bin for the links. I think
RedHat must install python in /usr/bin by default, but the fresh install
puts it in /usr/local/bin.