[Tutor] win32com on activepython 2.3

Karl Fast karl.fast at pobox.com
Mon Nov 10 22:35:01 EST 2003

This probably isn't the right list for this question, but maybe some
here can help.

I've got code to create a win32 COM client. It worked fine under
Python 2.2 (ActivePython). I just upgraded to the new ActivePython
2.3 and it doesn't work.

In the shell if I do this:

    import win32com.client

I get this traceback:
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
  File "D:\python\Lib\site-packages\win32com\client\__init__.py",
  line 12, in ?
    import dynamic, gencache, pythoncom
  File "D:\python\Lib\site-packages\win32com\client\gencache.py",
  line 623, in ?

  File "D:\python\Lib\site-packages\win32com\client\gencache.py",
  line 52, in __
  File "D:\python\Lib\site-packages\win32com\client\gencache.py",
  line 610, in R
  File "D:\python\Lib\site-packages\win32com\client\gencache.py",
  line 57, in _S
    raise RuntimeError, "Trying to write to a readonly gencache
    ('%s')!" \
RuntimeError: Trying to write to a readonly gencache

It all worked until I upgraded.

I can go back to 2.2, but I don't know if this is

  (a) a problem with the latest ActivePython
  (b) a problem with the latest win32 extensions
  (c) me doing something wrong and getting away with in 2.2

Anyone able to help?

I'm actually importing it like so, but I still get the same "trying
to write to a readonly gencache" error....

  from win32com.client import constants, Dispatch


More information about the Tutor mailing list