[Tutor] Coding philosophy

David Rock david at graniteweb.com
Fri Apr 30 17:08:55 EDT 2004

* firephreek <firephreek at earthlink.net> [2004-04-30 10:28]:
> Is it 'wrong' to add fucntions to your program that only make the code
> 'easier' to read and write?
> For example, I'm working on that wxPython program, and rather than
> create a different name for each 'row' in the notebook layout, or even a
> numbered array, I 'enumerated' a dictionary so that I can reference a
> row by the name I give it.  

Nothing wrong with it at all. Actually, it's very Pythonic to make
something more readable.

David Rock
david at graniteweb.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://mail.python.org/pipermail/tutor/attachments/20040430/4dcdf755/attachment.bin

More information about the Tutor mailing list