[Tutor] LiveWires problems

ZIYAD A. M. AL-BATLY zamb at saudi.net.sa
Mon Aug 15 19:12:47 CEST 2005

On Mon, 2005-08-15 at 11:52 -0400, Michael Murphy wrote:
> Hi all
> I'm having problems with installing LiveWire for python for Linux
> (Linspire 5.0 to be exact) and I'm having trouble compiling setup.py.
> Heres the results:
> running install
> running build
> running build_py
> running install_lib
> creating /usr/lib/python2.3/site-packages/livewires
> error: could not create '/usr/lib/python2.3/site-packages/livewires':
> Permission denied
> I'm new at this but I'm sure this is an easy fix but I can't figure it
> out, any help is appreciated.
Most likely you need "root" privileges to change anything under "/usr".
If you trust the code, try running it again as "root" (also known as
"super-user").  Only do that if you're certain that the code is clean
(i.e. no viruses, trojans, spyware and/or worms)!

(Sorry, I don't know anything about Linspire, or else I would guide you
step by step on how to do that!.  In general, try "sudo" with your own
password, or "su" with root's password.)

More information about the Tutor mailing list