[Tutor] Berkeley db incompatibility

Bill Campbell bill at celestial.net
Fri Mar 4 22:02:11 CET 2005

I don't know that this is a tutor topic, but since I'm a python newbie,
I'll try.

Building python-2.4 with db-4.3.27 fails on an undefined enum, DB_LSTAT_ERR
resulting in no bsddb module.  It looks like the sleepycat folks decided to
break backwards compatibility by dropping this out of the enum.

I've tried google to find a fix, but haven't found anything yet.

Is there a recommended fix for this?

INTERNET:   bill at Celestial.COM  Bill Campbell; Celestial Software LLC
UUCP:               camco!bill  PO Box 820; 6641 E. Mercer Way
FAX:            (206) 232-9186  Mercer Island, WA 98040-0820; (206) 236-1676
URL: http://www.celestial.com/

The Constitution is a written instrument.  As such, its meaning
does not alter.  That which it meant when it was adopted, it
means now.
-- SOUTH CAROLINA v. US, 199 U.S. 437, 448 (1905)

More information about the Tutor mailing list