[Tutor] smtplib starttls() error

Kent Johnson kent37 at tds.net
Wed Jan 10 12:05:55 CET 2007

Olen wrote:
> Hi Kent and Terry,
>              Correct I am using Active state python,and did not read
> the full information about installations. Thank you for for the
> information.
> I just need to confirm something, In python when we "upgrade" we
> essentially install a new
> version of python , and we would be needing to install what ever
> custom packages we have previously installed right?

For major version upgrades (2.x -> 2.x+1) that is correct. For minor 
upgrades (2.x.y -> 2.x.y+1) the new version usually installs over the 
old and uses the same custom packages. I don't know what happens if you 
install the python.org distribution over an ActiveState distribution, 


More information about the Tutor mailing list