[Tutor] Python, CGI and CSS

Alex Krycek agent.krycek at gmail.com
Fri Apr 11 05:05:49 CEST 2008

Thank you all for your help. I've finally figured it out. I took people's
suggestions and typed in the path for the CSS file into my browser. Well, I
received an internal service error. When I checked the error log, I had
received the following:

[Thu Apr 10 20:38:47 2008] [error] [client ::1] (8)Exec format error: exec
of '/usr/local/apache2/cgi-bin/style1.css' failed

If I understand this correctly, Apache was apparently trying to execute my
CSS file. So I moved the CSS file into my /~username/Sites folder (I'm on a
Mac), changed the href link in my Python script, and finally my CSS rules
were applied to the selected XHTML. I read somewhere that it's not a good
idea to have anything other than scripts in one's cgi-bin anyways. Thanks

On Thu, Apr 10, 2008 at 3:22 PM, Kent Johnson <kent37 at tds.net> wrote:

> Alex Krycek wrote:
> > Eric,
> >
> > I'm sorry, I never actually managed to get any stylesheets to work with
> > my cgi scripts. The scripts that did work are just simple HTML.
> >
> Where are the css files that work located? What URL is used to fetch them?
> If you put the css for your cgi into the same location and fetch with a
> similar URL it should work.
> Kent
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mail.python.org/pipermail/tutor/attachments/20080410/0a82bf7e/attachment.htm 

More information about the Tutor mailing list