[Tutor] Can't start IDLE 2.6 on Mac

Kent Johnson kent37 at tds.net
Mon Oct 20 12:42:01 CEST 2008

On Sun, Oct 19, 2008 at 5:53 PM, Rob Stevenson <rob.rstevenson at gmail.com> wrote:
> Hello,
> A slightly different question.  I use python on vista but recently bought a
> mac laptop running tiger so I could use garageband.
> I decided to put 2.6 on it but even though it installs fine, when I go to
> Applications / Python 2.6 and double click IDLE, nothing happens.

Unfortunately there is a problem with the Mac release of Python 2.6
and Tkinter (which IDLE uses) does not work correctly. The only fix at
this point is to use 2.5 or to build Python yourself.

I hope there will be an official release that fixes this soon, it
seems like a serious problem to me.


More information about the Tutor mailing list