[Tutor] building Python 2.6?

Bernard Rankin berankin99 at yahoo.com
Thu Jan 29 04:01:24 CET 2009


I am trying to build python 2.6 on a machine (web server) that I do not have root access to. (has 2.4 installed)

Python 2.5 builds fine, but I am getting an error when I run "make" for 2.6.1

Here is the command line I am using:
../configure -prefix=/home/username/local-python/ --enable-unicode=ucs4

(I don't know what the ucs4 thing is, but all the HOWTOs I saw say to use it. )

Here is what the local python reports itself as:

Python 2.4.3 (#1, Jul 29 2007, 14:09:31) 
[GCC 3.4.6 20060404 (Red Hat 3.4.6-8)] on linux2

Here is the error after I run "make":
/home/username/local-src/Python-2.6.1/Modules/_ctypes/_ctypes.c:3941: error: syntax error before '*' token
/home/username/local-src/Python-2.6.1/Modules/_ctypes/_ctypes.c:3942: warning: function declaration isn't a prototype
/home/username/local-src/Python-2.6.1/Modules/_ctypes/_ctypes.c: In function `CFuncPtr_nonzero':
/home/username/local-src/Python-2.6.1/Modules/_ctypes/_ctypes.c:3943: error: `self' undeclared (first use in this function)

Failed to find the necessary bits to build these modules:
_tkinter           bsddb185           sunaudiodev     
To find the necessary bits, look in setup.py in detect_modules() for the module's name.

Failed to build these modules:

running build_script                                         


More information about the Tutor mailing list