[Tutor] i can't for the life of me get "#! /usr/bin/env python" or "#!/usr/bin/python" to work

Jason Willis chaoticslacker at gmail.com
Wed Oct 21 20:21:23 CEST 2009

hi everyone,

sorry for the rather boring question but i'm having serious issues getting
my programs to run from the command line without having to type "python"
in-front of them. I've tried a lot of different variations on the
#!/usr/bin/ etc. line and have come up with the following every time:

*[root at localhost moonshinerat]# mycode.py
bash: mycode.py: command not found
[root at localhost moonshinerat]# mycode
bash: mycode: command not found
[root at localhost moonshinerat]#

I've chmod'ed the program and everything but i still get command not found
from the shell. The only thing that does work is ./mycode.py but from what i
understand that's been built into linux itself to work that way...

please someone let me know what i'm doing wrong here and possibly help??


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/tutor/attachments/20091021/fa808872/attachment.htm>

More information about the Tutor mailing list