[Tutor] pyMVPA and OSError

Luke Paireepinart rabidpoobear at gmail.com
Sat Feb 20 18:07:05 CET 2010

On Thu, Feb 18, 2010 at 10:23 AM, Juli <la.foma at gmail.com> wrote:

> Dear All,
> I am very much new to python, therefore I am likely to feel stupid
> about asking this. I need pyMPVA module to play around with some fMRI
> data. I have installed Python2.6 on Mac OS X Leopard. When I input >>>
> import mvpa i get a deprecation warning, which is not a problem,
> however when I try the following: >>> >>> import mvpa.suite as mvpa i
> do not get a deprecating warning however I get a number of errors that
> are as follows:
> >>> import mvpa.suite as mvpa

In addition to what Yaroslav mentioned, I may also suggest that it's
probably not a great idea to import a sub-package as the base package's
name.  You may have problems later if you want to import from mvpa. I.E. it
would be better to say
import mvpa.suite as suite
from mvpa import suite

Also I think you are supposed to use the syntax
from mvpa import suite as foobar
import mvpa.suite as foobar

but I'm not sure.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/tutor/attachments/20100220/05f723eb/attachment.htm>

More information about the Tutor mailing list