[Tutor] Cannot open SQLite database

ALAN GAULD alan.gauld at btinternet.com
Thu Feb 25 09:49:43 CET 2010

> >     It is on Windows XP, and in the logfile it says it uses the directory:
> >     C:\Documents and Settings\user\Application Data\myapp
> >
> >     That directory should always be writeable for the user, no?
> >
> >     Not on my PC its Read Only....
> >
> > And I have administrator rights.
> > A normal user is even more likely to be limited.
> > And a Guest account definitely would be.
> Hmm that's strange. I thought the application data folder is the correct 
> folder on Windows systems to put your configuration files. And until 
> now, it worked perfectly for every user.
> What should be the correct folder then?

I don't know! To be honest I was surprised by the result too.
Personally I tend to either use the application folder or the registry.
But the app folder doesn't work for user specific settings unless 
you have a separate file based on user ID.

Its very odd.

In fact Windows explorer appears to be lying. I just tried creating 
a file using Python and it worked perfectly. But Explorer definitely 
claims its R/Only! I also tried the ATTRIB command from DOS 
and it does not show it as Read only. 

Cygwin shows it as readonly for world access but open for user 
and group. The security tab in exporer shows it read/write for
admins and me. (It doesn't show a world setting)

So I think that was a red herring, sorry.
It also looks like the Read Only check box in the main Explorer 
property dialog tab doesn't mean what it says...

Alan G.

More information about the Tutor mailing list