[Tutor] How to get both 2.6 scripts as well as 3.1 scripts to run at command line?

Richard D. Moores rdmoores at gmail.com
Thu Sep 16 06:11:02 CEST 2010

On Wed, Sep 15, 2010 at 20:25, Richard D. Moores <rdmoores at gmail.com> wrote:

> 64-bit Vista.
> I have no problem running 3.1 scripts at the command line. However 2.6
> scripts seems to require 2.x. For example, I get this error showing that the
> old 2.x print won't do:
> C:\P26Working\Finished>solveCubicEquation.py
>   File "C:\P26Working\Finished\solveCubicEquation.py", line 19
>    print "a is", a
>                ^
> SyntaxError: invalid syntax
> Dick Moores

Seems I was misunderstood.

Some of the scripts written for 2.6 use libraries not yet available for 3.x.
So I want to know not how to modify them, but how to run them at the command

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/tutor/attachments/20100915/b15f58dc/attachment.html>

More information about the Tutor mailing list