[Tutor] Auto-detecting of Python version - wrong!

Elisha Rosensweig benshafat at gmail.com
Mon Aug 29 11:46:29 CEST 2011

Hi All,

I'm trying to use easy_install on my Mac to get the Python networx package.
On my machine I have installed version 2.5 AND 2.6 of Python. However, wehn
I try to install this package, I get:

easy_install networkx
Searching for networkx
Reading http://pypi.python.org/simple/networkx/
Reading http://networkx.lanl.gov/
Reading http://networkx.lanl.gov/download/networkx
Reading http://sourceforge.net/project/showfiles.php?group_id=122233
Reading http://networkx.lanl.gov/download
Reading http://networkx.lanl.gov
Reading https://networkx.lanl.gov
Best match: networkx 1.5
Downloading http://networkx.lanl.gov/download/networkx/networkx-1.5.zip
Processing networkx-1.5.zip
Running networkx-1.5/setup.py -q bdist_egg --dist-dir
*NetworkX requires Python version 2.6 or later (2.5 detected).*
error: Setup script exited with -1

this, despite the fact that my default python is version 2.6:

Python *2.6.2* (r262:71600, Apr 16 2009, 09:17:39)
[GCC 4.0.1 (Apple Computer, Inc. build 5250)] on darwin

Any ideas how to solve this?

Thanks in advance,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/tutor/attachments/20110829/26b13941/attachment-0001.html>

More information about the Tutor mailing list