[Tutor] The Perennial 3.2 vs 2.7

Wayne Werner waynejwerner at gmail.com
Fri Nov 18 06:58:33 CET 2011

Forwarding on to the list... (hit reply to all next time)

On Thu, Nov 17, 2011 at 8:45 PM, Mark Lybrand <mlybrand at gmail.com> wrote:

> so, use my 2.7 and not my 3.2 for my study? Or use my 3.2 for study and
> then do what I have to in 2.7 after including those lines?
> Thanks for the quick reply by the way. I am still struggling with the loss
> od curly braces :)
Honestly it probably doesn't matter. Many 3rd party libraries have now been
ported to Python 3.x, so unless you have a particular library you're
interested in, I would start with 3.2 until you find something you can't do.

As far as the curly braces go... just think about everything that isn't
really programming, but telling the compiler something. Get rid of it, and
you probably have Python... and you can always try:

from __future__ import braces

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.python.org/pipermail/tutor/attachments/20111117/dc4e69bb/attachment.html>

More information about the Tutor mailing list