[Tutor] Can not install pycrypto on Windows 64bit with cygwin(python27)

Muse Gk goknmuse at gmail.com
Sat Sep 22 06:25:42 CEST 2012

eryksun (), thanks for your help.

I had tried MinGW-w64 today, however, another more errors happen which
just like this (
). Another no solution error.

First, I tried to remove all instances of -mno-cygwin in
distutils\cygwinccompiler.py and got another different error.

Second, keep -mno-cygwin in distutils\cygwinccompiler.py, tried a
little version of  MinGW-w64 (
). This time finally kill the error "gcc: error: unrecognized command
line option '-mno-cygwin' ", however, got another one "collect2: ld
returned 1 exit status" instead.

It seems there is no way I can kill all errors. It took me hours and
hours to kill those errors, however, there is still another one. I am
feeling very depressed. I do not want to install pycrypto any more. :(

I hope there will be an easy way to install it in the short future.


On Sat, Sep 22, 2012 at 2:32 AM, eryksun <eryksun at gmail.com> wrote:
> On Fri, Sep 21, 2012 at 12:26 PM, Muse Gk <goknmuse at gmail.com> wrote:
>> I have the very similar problem like this guy except I want to install
>> pycrypto ( https://www.dlitz.net/software/pycrypto/ ).
>> http://stackoverflow.com/questions/12005109/python-cannot-build-pycpuid
> Try MinGW-w64 running under Windows instead of Cygwin:
> website
> http://mingw-w64.sourceforge.net/
> rubenvb toolchain
> http://sourceforge.net/projects/mingw-w64/files/
> Toolchains%20targetting%20Win64/Personal%20Builds/rubenvb/gcc-4.7-release/
> Shortened URL for the above:
> http://goo.gl/Igujs

More information about the Tutor mailing list