[Tutor] installing openpyxl, problem still n o t solved

Steven D'Aprano steve at pearwood.info
Mon Jul 25 23:57:37 EDT 2016

Hello Marcus,

I'm afraid it is very difficult for me to understand your email. Your 
email contains weird control characters as shown here:

On Mon, Jul 25, 2016 at 08:59:50PM +0200, marcus lütolf wrote:
> Dear Experts, 
> I was too optimistic. Module ‚jdcal‘ ist indeed installed.
> However, I get another trace back concerning ‚et_xmlfile‘ even after I
> downloaded and saved it the same way as I did with ‚jdcal‘.

I think the reason is that your email program is setting the wrong 
encoding: your email claims to be Latin-1 but obviously isn't.

I think this may be because you are using Microsoft Word as the email 
editor, and inserting "smart quotes", probably ‘’. Smart quotes are not 
part of Latin-1, but Outlook is (wrongly!) setting a header saying that 
it is using Latin-1.

You should be able to fix this by:

- turning of Smart Quotes and using ordinary '' or "" quotes instead of 
  curly quotes ‘’ or “”

- teaching Outlook to use UTF-8 instead of the cp1252 encoding

- or at least have Outlook say it is using cp1252 instead of wrongly 
  claiming to be using Latin-1

That will help us be able to read your emails.

Another problem is that I actually don't understand what you are saying. 
First you say that you were too optimistic, at the beginning of the 
email. Then in the middle of the email you say you have solved your 
problem, and we should not bother. Then at the beginning you say that 
you need help. None of these parts are quoted:

   > Quoted text

   Not quoted text

so it all looks like part of the same email, which is confusing: have 
you solved the problem? Not solved it?

If we understood your questions better, perhaps we could answer them.

> Since I haven’t got any responses to my previous calls for help – my problem
> might be too unimportant - I just try it another time:
> Why got ‚jdcal‘ accepted and ‘et_xmlfile’ not ?
> I must say I unzipped both files directly in
> C:\Users\marcus\AppData\local\Programs\Python\Python35\Lib\site-packages.

Are you talking about this?


You should unzip it into your home directory, and then run the setup.py 
file in the top directory. I think the command will be:

python setup.py install

as administrator or root superuser. On Linux/Mac you may be able to use:

sudo python setup.py install

> The command  >pip install was rejected as SyntaxError : invalid syntax.
> Thanks for any kind of help, Marcus.

You need to run pip from the operating system's shell, not from inside 
Python. Python's default prompt is ">>>". Most shells use "$" or "%" as 
the prompt.


More information about the Tutor mailing list