[Tutor] Fwd: Re: Python Help

Alan Gauld alan.gauld at yahoo.co.uk
Sun Jul 23 16:42:26 EDT 2017

Forwarding to list

-------- Forwarded Message --------

I did use the pip command and am attempting to add the files to my
python path. I used
 import sys

and that worked. I even checked to make sure the files were there 

import sys
print (sys.path)

['', '/Users/Jim/anaconda/lib/python36.zip',
'/Users/Jim/.ipython', 'Users/Jim/Documents/illustris_python']

the file is clearly there but when i try to do import illustris_python
as il it still can't find the module. 

I also figured that I need to manually export to python path so i tried:
export PYTHONPATH=$PYTHONPATH:/Users/Jim/Documents/illustris_python/
  File "<ipython-input-14-30d153a77da5>", line 1
    export PYTHONPATH=$PYTHONPATH:/Users/Jim/Documents/illustris_python/
SyntaxError: invalid syntax

I got invalid syntax... using a mac os x

I tried typing in terminal open .bash_profile and telling it to export
the python path in there like some others recommended but in terminal it
is giving me an error message for that... it must not be the right
command for the shell.


On Sat, Jul 22, 2017 at 9:34 PM, Cameron Simpson <cs at zip.com.au
<mailto:cs at zip.com.au>> wrote:

    On 23Jul2017 00:20, Alan Gauld <alan.gauld at yahoo.co.uk
    <mailto:alan.gauld at yahoo.co.uk>> wrote:

        On 22/07/17 19:14, Winonah Ojanen wrote:

            using python with anaconda in jupiter notebook. However, I
            am having

        Usual caveat: The tutor list is targeted at the standard library
        so any help for non standard library modules is best sought from
        the library support fora. In this case that includes the SciPy forum
        and any illustris one.

    Though arguably the OP's problem is an import issue, not really
    module specific.

        That having been said, I'll take a guess...

            $ mkdir Illustris-3
            $ mkdir Illustris-3/groups_135

        Are these folders in your PYTHONPATH? If not Python will not
        find them.

            import illustris_python as il
            ModuleNotFoundError                       Traceback (most
            recent call last)

    The OP cded into the new dir; I'd normally expect things to be found
    if the module was a local file/dir. However...

            For some reason the computer is not recognizing this as a
            file on my
            computer. The CCA folks says this is a coding problem and
            not an illustris
            problem. any ideas to get me past this? I may also need help
            farther into the download process.

    I just ran the OP's download command:

     wget -nd -nc -nv -e robots=off -l 1 -r -A hdf5
    --content-disposition --header="API-Key:

    This doesn't seem to download any Python code at all. It does get a
    couple of HDF files, presumably with data to work with.

    So the issue is initially that the module isn't present anywhere.
    Looking at the instructions cited
    <http://www.illustris-project.org/data/docs/scripts/>>, they only
    cover fetching som data and working; they presume the software is
    already present. I don't immediately see actual software
    installation instructions, and it is not presented in PyPI.

    Most like the OP will have to install the software directly from:


    This command:

     hg clone

    should produce an "illustris_python" in the current directory, and
    then her import command will find it.

    However, there are other prerequisites. This pip command:

     pip install h5py numpy

    seems to resolve them. The OP will need to use Python 2 because the
    module seems to rely on a relative import (for its "util.py" file).

    Cameron Simpson <cs at zip.com.au <mailto:cs at zip.com.au>>

    Tutor maillist  -  Tutor at python.org <mailto:Tutor at python.org>
    To unsubscribe or change subscription options:

More information about the Tutor mailing list