[Tutor] How to write a function which reads files

boB Stepp robertvstepp at gmail.com
Wed Aug 8 21:30:08 EDT 2018


On Tue, Aug 7, 2018 at 9:13 AM Rafael Knuth <rafael.knuth at gmail.com> wrote:

> Alan Gauld wrote:
> > Also, consider using snake_case instead of PascalCase for your
> > function name, since the latter is typically used for classes, and
> > perhaps call it read_file to better describe it?
>
> thanks, I wasn't aware of the naming conventions for functions and classes.
> will bear that in mind!

Have you had a look at PEP 8 yet?  It covers most of the Python
stylistic conventions, particularly if you intend to contribute to
Python and its standard libraries.  It may be found at:
https://www.python.org/dev/peps/pep-0008/



-- 
boB


More information about the Tutor mailing list