[Tutor] pip stopped working gives error

Jim jf_byrnes at comcast.net
Thu May 3 15:10:36 EDT 2018

I have python 3.6 installed in a virtual environment on Mint 18. Today I 
wanted to use pip and got this error when I tried to use it.

  (env36) jfb at jims-mint18 ~ $ pip help
Traceback (most recent call last):
   File "/home/jfb/EVs/env36/bin/pip", line 7, in <module>
     from pip import main
"/home/jfb/EVs/env36/lib/python3.6/site-packages/pip/__init__.py", line 
43, in <module>
     from pip.utils import get_installed_distributions, get_prog
line 23, in <module>
     from pip.locations import (
"/home/jfb/EVs/env36/lib/python3.6/site-packages/pip/locations.py", line 
9, in <module>
     from distutils import sysconfig
ImportError: cannot import name 'sysconfig'

I searched for sysconfig and found this:


The results seem to be the same as when I searched a python 3.5 virtual 
environment I have setup.

It has worked in the past as I have installed pylint and pykeyboard with 
it. As I type this I just remembered Mint updated python 3.6 earlier today.

So now I suspect the update is involved. Has anyone else experienced 
this and know how to fix it?

Thanks, Jim

More information about the Tutor mailing list