[Web-SIG] *Another* implementation error

Phillip J. Eby pje at telecommunity.com
Wed Oct 6 08:42:21 CEST 2004

At 07:26 PM 10/5/04 -0400, Phillip J. Eby wrote:
>Just a quick heads-up...  there's an error in the PEP's CGI 
>implementation, so if you are basing a server/gateway implementation on 
>it, you may be copying this error into your own code.

This time, the culprit is:

     environ['wsgi.last_call']    = True

Which I apparently never updated when the name of the variable became 
'wsgi.run_once'.  Please check to make sure you didn't copy this error into 
your implementations.  Sorry for the inconvenience.

I've just checked in an update of the PEP to fix this and the other coding 
errors I found today.

More information about the Web-SIG mailing list