[XML-SIG] Python 1.5.2b1's xmllib.py Considered Harmful

Fredrik Lundh fredrik@pythonware.com
Tue, 26 Jan 1999 11:25:45 +0100


xmllib.py currently got a completely new interface in 1.5.2b1.
The new interface silently breaks all existing implementations
(it no longer calls start and end handlers), something that has
caused us a LOT of trouble lately.  For example, our highly
successful xmlrpclib.py implementation doesn't work at all
under 1.5.2b1.

I hereby propose that the old implementation of xmllib.py
should put back in Python 1.5.2 final, and that the new
incompatible version is shipped under a new name (e.g.
xmllib2).  I don't mind if the old version is deprecated,
just don't remove it from Python before 2.0.

Regards /F
fredrik@pythonware.com
http://www.pythonware.com