[XML-SIG] Newbie question not answered?

Jeff.Johnson@icn.siemens.com Jeff.Johnson@icn.siemens.com
Tue, 16 Mar 1999 10:33:07 -0500

>>>>> "Andrew" == Andrew M Kuchling <akuchlin@cnri.reston.va.us> writes:

    Andrew> Jeff.Johnson@icn.siemens.com writes:
    >> The instructions neglect to tell us to set the environment
    >> variable "HOME" to the directory that you want the xml package
    >> copied to.  Once you do that, it should work.

    Andrew>    Hm?  That's not necessary on Unix; won't CVS on
    Andrew> Windows place the files relative to the current directory
    Andrew> when you do a checkout?

    Jody>cvs on windows works the same way that cvs on unix.

After Jody confirmed that CVS works on Windows I tried an experiment.  CVS
works without 'HOME' if I run it from my C: drive.  If I run it from an NT
network share, it fails.

I don't know if this is a bug or not.  Sorry for not testing this on a
local drive earlier.

For the benefit of bug-cvs@gnu.org I shall repeat the error message:

Here's the output without 'HOME' set, 'F:' is a network share from NT 4.0:

F:\cvs>cvs -d :pserver:xmlcvs@cvs.python.org:/projects/cvsroot login
(Logging in to xmlcvs@cvs.python.org)
CVS.EXE [login aborted]: could not find out home directory: No such file or

F:\cvs>cvs -z3 -d :pserver:xmlcvs@cvs.python.org:/projects/cvsroot co xml
CVS.EXE [checkout aborted]: could not find out home directory