[XML-SIG] Trying to install (Re: ANN: 4XPath 0.9.0 and 4XSLT 0.9.0)

Karl Eichwalder ke@gnu.franken.de
01 Jun 2000 18:34:01 +0200

uche.ogbuji@fourthought.com writes:

>                       4XSLT and 4XPath 0.9.0

Thanks for the new release!  I'm trying to install your packages on SuSE
Linux 6.4 (and I'd like to add them to our distribution).

SuSE Linux comes with Python XML Tools 0.5.1; are they new enough?
4DOM.html doesn't specify a special version.

Reading the documentation I've the impression I've to install 4DOM first
(4DOM-0.10.0.tgz).  I adjusted 4DOM.spec a little bit and I was able to
build a package.  Running

    python /usr/doc/packages/4DOM/demo/dom_from_html_file.py \

Ft.Lib was missing.  After copying the Ft directory coming with
4DOM-0.10.0.tgz to the site-packages directory the error message

Traceback (innermost last):
  File "/usr/doc/packages/4DOM/demo/dom_from_html_file.py", line 3, in ?
    from xml.dom.ext.reader import HtmlLib
  File "/usr/lib/python1.5/site-packages/xml/dom/ext/__init__.py", line 18, in ?
    from xml.dom.Node import Node
  File "/usr/lib/python1.5/site-packages/xml/dom/Node.py", line 12, in ?
    from xml.dom import implementation
ImportError: cannot import name implementation

Now I need your help to solve this problem, please.

[ NB. http://Fourthought.com has several dead links.  E.g., it refers to
  .tar.gz files but actually .tgz files are offered. ]

work : ke@suse.de                          |
     : http://www.suse.de/~ke/             |          ------    ,__o
home : ke@gnu.franken.de                   |         ------   _-\_<,
     : http://www.franken.de/users/gnu/ke/ |        ------   (*)/'(*)