[XML-SIG] Error using xml.sax.{xmlreader,expatreader}

Lars Marius Garshol larsga@garshol.priv.no
30 Nov 2000 10:54:03 +0100

* kthangavelu@earthlink.net
| [characters(...)]
| is this a python deviation, or am i just unable to find the latest
| spec?

This is a Python deviation.

The rationale for having this interface in Java is that it is very
much faster than the more obvious alternative of simply passing a

That was also the rationale for having it in SAX 1.0.  However, it
turned out that the only parser that took advantage of it was xmlproc,
and if speed is your main concern you should use pyexpat. Furthermore,
that interface was relatively painful to use and also slowed down
applications that used any other parser than xmlproc.

For this reason it was decided to do things differently in SAX 2.0.

| [...] also is there any intention of maintaining a legacy sax
| interface for older applications?

Well, I didn't think anyone would be interested, since it's such a
simple thing to convert code from 1.0 to 2.0, but if there is interest
I can add it to my todo list for the saxtools package.

--Lars M.