[XML-SIG] Re: [4suite] Article about XSLT 1.1 and <xsl:script>

Martin v. Loewis martin@loewis.home.cs.tu-berlin.de
Thu, 1 Mar 2001 22:43:34 +0100


> I was not accusing you or anything. Just being curious. I remember hearing
> you pestering about some stuff in numbering handling (or date handling,
> I'm not sure) in XSLT, which was Java biased (and this does not appear in
> the petition, as far as I can tell), but could not see what was the thing
> with DOM. 

For XSLT numbers, the spec indeed defines exactly the same floating
point semantics as used in Java. That is not a bad thing in itself, as
the Java meaning is a variant of IEEE 754 (i.e. selecting specific
options where the spec leaves options).

On the DOM, I notice a number of Java-isms, all of them minor:

- naming conventions. OMG style would be has_feature and
  get_dom_implementation, W3C style is hasFeature and getDOMImplementation.

- nesting. IMO, enums should be in module scope; W3C puts them in
  interface scope - presumably since Java does not allow package-level
  constants.

> Now, as for the bindings, I have to admit that it is one part of the spec
> that I have never looked at (I've just checked it 30 seconds ago to see
> what it looks like, and I really do not see the point in putting this in
> the spec. It brings nothing new, and the IDL is all you need.)

You do need it, as it does not follow the CORBA language
mappings. E.g. everything is in a module "dom", but that ends up as
package org.w3c.dom in Java, and xml.dom in Python. Likewise, the
"readonly attribute nodeType" maps to getNodeType() in Java, whereas
the IDL mapping would produce a method named nodeType().

You probably could have done all that by spelling out the mapping
rules instead of providing the mapping result; in Java, it is easier
just to write down the interface definitions.

Regards,
Martin