[XML-SIG] Getting 4SuiteServer 0.11 Working on Windows

Thomas B. Passin tpassin@home.com
Sat, 5 May 2001 12:11:46 -0400

I've been able to get 4SuiteServer working on Windows98/Me, but it doesn't
quite work right out of the box as downloaded.  Here's what I needed to do
to get it working.

I did all the steps in the installation and quickstart guide.  Once it's
installed using the WIndows installer, you set up your environmental
variables, then you are told to run

4ss init

1) 4ss.bat is in the python\scripts directory, so you have to add it to your
path or have to be running in that directory.

2) The init command fails because the file "core.odl" is not installed into
the "generated" directory (or anywhere else) by the installer.  I downloaded
the source distribution, found the file, and copied into the generated

Now init works.

3) init works, but when it asks if you want to wipe out the old data, it
wants you to answer "yes" or "no".  Most Windows users are used to being
able to answer 'y' or 'n' to those questions.  I did, and didn't even notice
that I hadn't literally done what the prompt said.  Very Unix-like.  Very
unforgiving.  This code should be changed to allow "y" and "n" as well.

4) The quick start guide has you run the script populate.py in the
python\docs\4SuiteServer-0.11\demo directory.  But it fails, looking for a
unix file, something like /etc/mime.types.  The script has a test for this
file and an except branch to run in case it doesn't exist (which it doesn't
on a Windows machine).  But the except branch incorrectly has a "raise"
statement which terminates the script.

Get rid of this line, which is line 66 of populate.py. Now the script runs.

5) At this point, populate installed its downloaded files but failed when it
tried to modify "docdefs".  It turns out you have to be running as superuser
to change docdefs.  The guide doesn't tell you, but implies that you should
have run as the new user it just had you create.  Otherwise, why create that
user just before running populate.py?

I deleted the whole "gems" container and went through the steps again as

6) Then I tried to install and run the guestbook.  You have to run the
"bootstrap.py" script in the demo\GuestBook directory.  This failed.  It
turned out that you have to change to the GuestBook directory and run from
that, otherwise the script can't find the files it needs.

7) The Guestbook works until you try to submit the form for your first
guest.  Then it fails, but in a strange way.  With IE, I got an error
message saying it couldn't find the server or there was a DNS error.  This
must be an incorrect message since the form uses a relative path, but anyway
something isn't working that I haven't tracked down.

8) The docs give examples of looking at various properties by their path, as

4ss show acl /localhost/index.html

None of these commands have worked for me.  I had to remove the /localhost/
part.   My server was running at the time.

I think there was one more change I made to get init to work - there is a
path with a unix-style "/" hardcoded somewhere - but unfortunately I forget
just where and can't find it right now.  If this strikes, you should be able
to find it from the error message.

It runs now - I have it on port 8090 to avoid colliding with Zope in 8080.
Good luck!


Tom P