[XML-SIG] Getting 4SuiteServer 0.11 Working on Windows

Mike Olson Mike.Olson@fourthought.com
Sat, 05 May 2001 16:43:44 -0600

"Thomas B. Passin" wrote:

Thomas,  thanks for all of the work, I'm working today on getting these
straigtened out.

> 4ss init
> 1) 4ss.bat is in the python\scripts directory, so you have to add it to your
> path or have to be running in that directory.

This is in the Windows Installation guide.



Towards the end of the Installing 4SuiteServer section.

> 2) The init command fails because the file "core.odl" is not installed into
> the "generated" directory (or anywhere else) by the installer.  I downloaded
> the source distribution, found the file, and copied into the generated
> directory.

This was a packaging bug.  We will be putting out new Windows packages

> Now init works.
> 3) init works, but when it asks if you want to wipe out the old data, it
> wants you to answer "yes" or "no".  Most Windows users are used to being
> able to answer 'y' or 'n' to those questions.  I did, and didn't even notice
> that I hadn't literally done what the prompt said.  Very Unix-like.  Very
> unforgiving.  This code should be changed to allow "y" and "n" as well.

I'll make this more forgiving, and more informative.

> 4) The quick start guide has you run the script populate.py in the
> python\docs\4SuiteServer-0.11\demo directory.  But it fails, looking for a
> unix file, something like /etc/mime.types.  The script has a test for this
> file and an except branch to run in case it doesn't exist (which it doesn't
> on a Windows machine).  But the except branch incorrectly has a "raise"
> statement which terminates the script.
> Get rid of this line, which is line 66 of populate.py. Now the script runs.

Fixed in CVS, thanks.

> 5) At this point, populate installed its downloaded files but failed when it
> tried to modify "docdefs".  It turns out you have to be running as superuser
> to change docdefs.  The guide doesn't tell you, but implies that you should
> have run as the new user it just had you create.  Otherwise, why create that
> user just before running populate.py?

I updated the docs to say that populate needs to be run as super user. 
I might change it so that any user can create a document definition

> 6) Then I tried to install and run the guestbook.  You have to run the
> "bootstrap.py" script in the demo\GuestBook directory.  This failed.  It
> turned out that you have to change to the GuestBook directory and run from
> that, otherwise the script can't find the files it needs.

I updated the README

> 7) The Guestbook works until you try to submit the form for your first
> guest.  Then it fails, but in a strange way.  With IE, I got an error
> message saying it couldn't find the server or there was a DNS error.  This
> must be an incorrect message since the form uses a relative path, but anyway
> something isn't working that I haven't tracked down.

I'll have to look into this one a bit closer....

> 8) The docs give examples of looking at various properties by their path, as
> in
> 4ss show acl /localhost/index.html

Did you get an error of:
Uri /localhost/index.html, is unknown

> None of these commands have worked for me.  I had to remove the /localhost/
> part.   My server was running at the time.

Did it work when you removed the localhost part?  Then you probably have
a document in your root called index.html.  Probably from the Guestbook
example.  That souldn't put things in your root.

thanks again for your help.  Hopfully it is getting easier to install.


Mike Olson				 Principal Consultant
mike.olson@fourthought.com               (303)583-9900 x 102
Fourthought, Inc.                         http://Fourthought.com 
Software-engineering, knowledge-management, XML, CORBA, Linux, Python